Bug Reports JAN2013a

Status
Not open for further replies.
  • Thread starter
  • Admin
  • #1

Thothie

Administrator
Staff member
Administrator
Moderator
Lead MSC Developer
MSC Developer
Apr 8, 2005
16,199
256
lost
:arrow: = Working on it, :?: = wtf/unconfirmed, :idea: = fixed next release

Known issues

:?: Starting an HLDS or listenserver with the -num_edicts flag may lead to crashes on some maps.
- 1500 is now the default for clients. Servers should set their -num_edicts flags to 1500 as well, via the command line.

Major
:?: Spawning a largely full Galat chest may lead to server crash when withdrawing items
- This is actually a perpetual bug until we optimize the inventory systems.
- A full Galat chest is the resource equivalent of another character joining, so don't withdraw items unless you think the server can handle that at the time.

Minor
:idea: Phobia seems to get broken in the area where you first encounter snakes
:idea: ms_wicardoven skeletons near Maldora's Fragment event failing to spawn
:idea: shad_palace inacessable passed vent system (also may have been unloadable RKS servers - but that bit's fixed.)
:idea: similar issues with being unable to progress also reported on other maps (though not always consistent)
- including: aleyesu, phlames, possibly others, possibly intermitent...
:idea: Thunderbreaker doing Fire damage with normal attacks
:idea: Dwarven bolts exploding immediately when used with Steam Bow
:idea: Blood Drinker not passing XP when in flight
:idea: Healing with rejuv/HC not giving damage points
:idea: Hooke Iron Arrows failing to spawn
:?: ms_soccer cameras are hard to get out of if you move the mouse while using them
:?: shender_east: Buggy portals sometimes make fire giant inaccessible.

Aesthetic
:arrow: Jaminporlants is LOUD
:?: Texture scrambling issues when playing for a period of time
:?: Some players report additive render weapons not rendering so in first person, or otherwise rendering incorrectly (Felewyn Shard, Hoarfrost Blade, GIB, etc.)
:?: Disconnecting while dead results in invisible body and armor on reconnect.
:?: Using changelevel instead of votemap or admin_map may cause various texture issues.
:arrow: Some p_models vanishing into floor

Ancient/Perpetual
Known Ancient bugs:
- No Free Edict Errors (ED_Alloc:no free edicts), usually the result of overloading the server in one way or another. You can *try* hosting with the -num_edicts flag, however, this may prevent some maps from loading. We're constantly working to mitigate this bug.
- All entities invisible bug (type kill in console to cure).
- Lights/sprites not going away / sticking to other objects (Sticky client-side effects)
- Occasionally a weapon/spell will stop doing damage until it is unequipped then re-equipped.
- Can't use charge attack in laggy conditions. (Work around: use +special or +uber)
- Sitting animation bugs (sometimes saves to character for awhile)
- All water sometimes goes white (texture stretch bug, restart)
- Lack of level up sfx for Polearms (for some players)
- Typing issues in chat. Especially with European keyboards.
- Various Health/mana indicator madness (see also yonder)
- Small sack holds stuff it should not.
- Ticket Bank freaks if you have more than one of the ticket or item you are trying to trade
--> Galat chest does not have this issue.
- Double attack bug, most prominant with xbows
- All tomahawks appear as fire tomahawks in third person
- Heavy/Light Crossbow jamming when firing
- You cannot use NPC/GM/menus/chests when inventory is full (not a bug, insomuch a necessary limitation, at the moment.)


Also Not liable to go away soon:
- Jumping from server to server without closing |MSC screws with FN functionality
(solution: ALWAYS close MSC before joining or creating a new server!)
- Some monsters still capable of some acts while frozen (jumping, etc.)
- Orion Bow jamming sometimes, (I've no idea how to fix this without dropping the whole charged weapon concept.)

Resolved from APR2012a:
- Fixed: Summon Bear Scroll has wrong script on exploit/donator reward list
- All sorts of var conflicts causing "myserious" behavior
- Vote PVP function restored
- Fixed: Can't push monsters while under the effect of leadfoot potion
- Bloodrose Flesheater adds scroll/tome to be dropped at spawn, rather than death (may fix crash)
- Fixed Vampire Potion (Beware that drinking another vampire potion does not reset the timer)
- Hopfully fixed invincible Shadow Goblins
- Fixed boss flag on Clethin (Fire Guardian of Phobia forest)
- "Ring of Electrical Resistance" -> "Ring of Grounding" due to string length issues
- Weapon Strap description shortened, due to string length issues
- Fixed Felewyn's Elemental Guardians stunning/pushing folks they didn't actually hit
- Fixed bug where some monsters with an hp requirement range would spawn when they didn't actually qualify
- Fixed some mobs bypassing push resistances (Petrified Warriors, Ihotor)
- Fixed a potentially nasty bug with the Galat Storage Chest
- Fixed bugger up on Hunderswamp boss, and the Hunderswamp final chest
- Changing map while a status icon is active causes said status icon to become permanently "stuck" (should be fine if you use admin_map or transition points)
 

SilentDeath

New Adventurer
Blades of Urdual
Alpha Tester
May 16, 2006
264
0
34
California
was playing in ms_wicardoven got to the closed skele room just before the fragment and no skeles spawned after killing the enraged ones.
 
  • Thread starter
  • Admin
  • #3

Thothie

Administrator
Staff member
Administrator
Moderator
Lead MSC Developer
MSC Developer
Apr 8, 2005
16,199
256
lost
Maybe an issue with the new anti-stuck spawn system - it's kinda cramped in there, I'll have to see if I can reproduce. Though, even if they were stuck, they shoulda returned after 4 seconds... So... Hrmm... Might be something else.

A little warning about the Sorcerball cameras, I neglected to mention - if you +use one, be sure not to move your mouse afterwards - otherwise you won't be facing the button to release the camera, and will have a heck of a time getting out of it without suicide.

I suppose I should see if I can tweak up the entity to just release you when you click use anywhere.
 
  • Thread starter
  • Admin
  • #5

Thothie

Administrator
Staff member
Administrator
Moderator
Lead MSC Developer
MSC Developer
Apr 8, 2005
16,199
256
lost
FUUUUUUUUUUUUUU...

Gods... Didn't I re-write him scratch in an attempt to fix this already? :\

Beginning to wonder if it has nothing to do with him at all, and is instead something else going on when he dies.

Bloody hard to test - even with the dev commands, takes forever to get to him.
 

SilentDeath

New Adventurer
Blades of Urdual
Alpha Tester
May 16, 2006
264
0
34
California
shender_east has issues on the rks server loading bar gets stuck and saw this in console
"No detail texture mapping file: maps/shender_east_detail.tx"
It works with my listen server though
 
  • Thread starter
  • Admin
  • #7

Thothie

Administrator
Staff member
Administrator
Moderator
Lead MSC Developer
MSC Developer
Apr 8, 2005
16,199
256
lost
Hrmm... Just tested it on my DS and didn't get that... Eh - fairly certain I have detailed textures enabled on my client...

(Oh wait, no I don't...)

Try settings r_detailtextures 0 - and see if you get the same error. I don't think I ever got a detail texture file for Shender_East, but it seems it shouldn't crash without it. :\
 

Echo717

New Adventurer
Socialist Guild
Aug 22, 2008
698
2
27
Arizona
Just tried that, still gets stuck on loading, although the error doesn't show up in the console. It gets stuck on precaching resources on the loading screen.
 
  • Thread starter
  • Admin
  • #9

Thothie

Administrator
Staff member
Administrator
Moderator
Lead MSC Developer
MSC Developer
Apr 8, 2005
16,199
256
lost
I just went to shender_east on "RKS KSzone.com | US Chicago | MSC Server 05 | [FN]" ( 23.19.122.29:27015 ) with no problem. :\ With the detail textures on, no less. :\
 

Thothie

Administrator
Staff member
Administrator
Moderator
Lead MSC Developer
MSC Developer
Apr 8, 2005
16,199
256
lost
Think it crashed the server too... Hrmm...
 

Thothie

Administrator
Staff member
Administrator
Moderator
Lead MSC Developer
MSC Developer
Apr 8, 2005
16,199
256
lost
I dont have a texture detail file for the map on my client that didn't get into the betapack or anything... Have you tried a reboot maybe? I'm kinda running out of idears, lest someone else can duplicate this.
 

TheOysterHippopotami

Active Adventurer
MSS Developer
MSC Developer
RiP
DarkTide
Sep 6, 2009
1,213
41
31
Ms_snow is broken. The big bears and pigs never spawn, so the path to the ice queen and orc chieftain never open.

Edit: While dicking around on the borked map for about ten minutes, one single medium sized polar bear has spawned or otherwise appeared out of the blue. Killing him did not spawn any more monsters.

Double Edit: Many minutes later, another pig spawns.
 

Thothie

Administrator
Staff member
Administrator
Moderator
Lead MSC Developer
MSC Developer
Apr 8, 2005
16,199
256
lost
TheOysterHippopotami said:
Ms_snow is broken. The big bears and pigs never spawn, so the path to the ice queen and orc chieftain never open.

Edit: While dicking around on the borked map for about ten minutes, one single medium sized polar bear has spawned or otherwise appeared out of the blue. Killing him did not spawn any more monsters.

Double Edit: Many minutes later, another pig spawns.
Also can't duplicate...

If I were to hazard a guess - I'm thinking maybe you came in from an unusual transition, and missed the "start_mania" trigger?

S2Sg8BA.gif
Gotta hit that hill there...

But it just worked fine on an RKS server, so...

There are some other minor random spawns, so that'd explain the rest, at least.
 

Thothie

Administrator
Staff member
Administrator
Moderator
Lead MSC Developer
MSC Developer
Apr 8, 2005
16,199
256
lost
ArkenMilovat said:
When i use stuff Dirdje gave me my game just crash with error Unlocated memory...
kinda forgot that due joy it works fine without it. :oldlol:
Welcome back...

...as in items, settings, or what? Still need to get Dridje to write up that guide - unless you mean his advice is causing you to get memory dealloc errors.

(@ TheOysterHippopotami - see bottom of previous page.)
 

Thothie

Administrator
Staff member
Administrator
Moderator
Lead MSC Developer
MSC Developer
Apr 8, 2005
16,199
256
lost
Yer getting a memory delloc crash when selecting your char? Sounds like char corruption. Maybe rollback?

So I ran through Bloodrose, for the 100th time, and still no crash... But I did get a lovely bug where Slithar's four chests didn't populate... Thought I fixed that too. :\ Damn this map...
 

zeus9860

Adventurer
Blades of Urdual
Crusaders
The True Followers of the Lost
Alpha Tester
Feb 28, 2008
2,549
18
27
lolwut
Shender_east loads perfectly fine outside of RKS servers (any other servers so to say). Just giving a heads up, it's playable on roghan's.
 

Thothie

Administrator
Staff member
Administrator
Moderator
Lead MSC Developer
MSC Developer
Apr 8, 2005
16,199
256
lost
RKS Chicago works fine for me, at least...
Thothie said:
I just went to shender_east on "RKS KSzone.com | US Chicago | MSC Server 05 | [FN]" ( 23.19.122.29:27015 ) with no problem. :\ With the detail textures on, no less. :\
...Are you getting this crash, or is it just SD?
 

zeus9860

Adventurer
Blades of Urdual
Crusaders
The True Followers of the Lost
Alpha Tester
Feb 28, 2008
2,549
18
27
lolwut
Damn these portals, they keep bugging out! They either vanish when they shouldn't, don't show up when they should or don't show up at all. :roll:
 

Thothie

Administrator
Staff member
Administrator
Moderator
Lead MSC Developer
MSC Developer
Apr 8, 2005
16,199
256
lost
Meh, probably just need to axe the whole idea of filtering the lower levels out.

...But you did not answer question... Are you having trouble getting there on RKS servers, or is it just SD?

Meanwhile, on Bloodrose: Fixed chests (both Slithar's and Athello's). Still can't make it crash though - not even on DS... Hrmm...
 

ArkenMilovat

New Adventurer
The Dragonknights
Feb 23, 2011
267
0
I am in this location!
Thothie said:
Yer getting a memory delloc crash when selecting your char? Sounds like char corruption. Maybe rollback?

So I ran through Bloodrose, for the 100th time, and still no crash... But I did get a lovely bug where Slithar's four chests didn't populate... Thought I fixed that too. :\ Damn this map...
i get crash ONLY when using Dirdje "lag fix" now without it game works normally (was horrible lags when looking on sprites before) by the way ms_soccer cameras, mayby better add something like 15 seconds timer? (no idea how to leave those exept cut my neck)
 

Stormshift

New Adventurer
DarkTide
May 16, 2006
100
0
31
US EAST
Figured I would throw my 2 cents in...

I fired up a few of the maps mentioned on my server and did not experience any crashes/hangs. Note: This was on a dedicated server, non-FN, with only me in the server.
I'll try them again with a buddy w/ FN online later on tonight.

Tundra spawns also worked fine for me aswell, just have to hit the "block" that triggers the spawns.

My only issues so far are the occasional texture/decal trip-outs and fonts going fuzzy, both of which are fixed by a simple restart, and luckily only happen once or twice a night.


To Thoth & everyone else who contributed to the patch/mod:
I appreciate you guys releasing a new patch, which came as a surprise to me. Just in time for my birthday too! I thank you all for the hard work and time you contributed to this patch. Another surge of life to MS:C... after the week I had, I definitely needed this, and I know others probably feel the same.

Thanks again,
-Stormshift
 
Status
Not open for further replies.
Top