Bug Reports FEB2015d

Status
Not open for further replies.
  • Thread starter
  • Admin
  • #1

Thothie

Administrator
Staff member
Administrator
Moderator
Lead MSC Developer
MSC Developer
Apr 8, 2005
16,199
256
lost
:?: = unconfirmed or not reproduced, :oldangry: = No clue, :arrow: = Working on it, :idea: = fixed next release

Known issues

:arrow: Starting an HLDS or listenserver with the -num_edicts flag higher than 1500 may lead to crashes on some maps.*
- 1500 is now the default for clients. Servers should set their -num_edicts flags to 1500 as well, via the command line.
- Valve broke listlib.gam "commandargs" functionality, so you must add this to your client launch options as well!
-- Go to Steam->Library
-- Right click on Master Sword Continued 1.2
-- Click "Properties"
-- Click "Set Launch Options"
-- Add -num_edicts 1500
- Sadly we've no way of doing this for you by via the installer.

Major
:oldangry: Very rarely, when multiple players transition between maps, all connected characters will be reset to level 0 and have their inventory wiped.*
- Your character will not save in this state, so there should be no damage done, however, reconnecting to the same server may or may not fix it (have yet to have a report on this.)
:arrow: Shields still be bjorked. (Generate massive lag and crashes - dun use em.)

Minor
:arrow: First client side arrow fired on each map may drop limply to the floor, like a disgusting wet sausage.
- Also unconfirmed reports of "every other arrow" failing to register hits.
:oldangry: HLDS server failing to close on game's request, under certain circumstances*
:idea: Deraliaswers: mbossdest needs multiple destinations*
:idea: b_castle: bodyguard_room needs multiple destinations*
:idea: Dragooncaves teleporter needs multiple destinations*
:idea: Lightning Forged Skeleton needs a new scan check sequence*
:oldangry: Two people with the same name can cause chat lag*
:oldangry: Being stunned while reloading sxbow seems to cause infinite reload loop*
- Re-equipping or redrawing (if hotkeyed) should fix.
:arrow: Applyeffect cooldowns seem to be jamming up from time to time*
:idea: Orc Poisoner casting stunning poison clouds on targets he cannot see
:( Short cut keys for menus have been disabled, probably permanently, due to exploits.
:?: Horror eggs crashing Cleicert/ms_wicardoven (cannot reproduce)
:idea: Golden axe repair quest crashing server
:?: Bear Gods crashing on death (not yet examined)
:?: Ddemonic Bludgeon Hammer being "unreliable" (not yet examined)
:oldangry: Occasionally weapons will do <1 damage.*
:idea: Throwing unholy blade with pvp on results in you hitting yourself (not yet examined)*
:idea: Forsuth shortcutting to the wrong teleport point after elevator, and sometimes not using teleport-catchup system.

Aesthetic
:arrow: Despite claims in changelog, Felewyn Shard is using new model. Otherwise, all should work as described.
:arrow: Some dwarves in Gatecity are using lanterns who probably shouldn't.
- Atm, lantern distribution is random - this will be fixed once the recompile is done.
:arrow: Elemental resistance updates sometimes fail to report to event HUD.*
:?: Smaller inventory icon inconsistencies.
:idea: Self-Adjusting treasure chests fubaring naming convention
:arrow: Various newer music not having the right time definitions, and thus and prematurely looping, or taking a long time to loop


* Persisting from SEP2013

Ancient/Perpetual Bugs
- All entities invisible bug (type kill in console to cure).
- Lights/sprites not going away / sticking to other objects (Sticky client-side effects)
- Occasionally a weapon/spell will stop doing damage until it is unequipped then re-equipped.
- Can't use charge attack in laggy conditions. (Work around: use +special or +uber or ms_autocharge 1)
- Sitting animation bugs (sometimes saves to character for awhile)
- All water sometimes goes white (texture stretch bug, restart)
- Lack of level up sfx for Polearms (for some players)
- Typing issues in chat. Especially with European keyboards.
- Various Health/mana indicator madness (see also yonder)
- Small sack holds stuff it should not.
- Double attack bug, most prominent with xbows
- All tomahawks appear as fire tomahawks in third person
- Heavy/Light Crossbow jamming when firing
- Some p_models vanishing into floor (report em though, still hunting)
- Periodic texture scramble issues
- You cannot use NPC/GM/menus/chests when inventory is full (not a bug, insomuch a necessary limitation, at the moment.)

Also Not liable to go away soon:
- Jumping from server to server without closing |MSC screws with FN functionality
(solution: ALWAYS close MSC before joining or creating a new server!)
- Some monsters still capable of some acts while frozen (jumping, etc.)
- Orion Bow jamming sometimes, (I've no idea how to fix this without dropping the whole charged weapon concept.)
- Spawning a largely full Galat chest on a busy server may lead to server crash when withdrawing items
- Some players report additive render weapons not rendering so in first person, or otherwise rendering incorrectly (Felewyn Shard, Hoarfrost Blade, GIB, etc.)
- Some mixed-rendered monsters may not render their additive bits on some systems
- Disconnecting while dead results in invisible body and armor on reconnect.
- Using changelevel instead of votemap or admin_map may cause various texture issues.
- ms_soccer cameras are hard to get out of if you move the mouse while using them

Resolved from FEB2015a/b/c:
- Shields be bjorked.
- Mobs vanishing from rmines.
- Abyssal Worm boss teleports to 0x0x0
- The_wall is unplayable (instant death on spawn).
- Certain global quests that take place between maps not functioning
- Scriptflag system failing, causing issues with shields, bear claws, music, push resistance, and others.
- NPC generated Circle of Death doing no damage (possibly some other NPC AOE's)
- Bloodrose chests being screwy, when you can get to them at all.
- Boss tag XP issues
- Dwarven bombers may become invulnerable if frozen during death sequence
- Some of the mobs who had their push DOT fixed, do no DOT at all.
- Boss tag for Iron Golem on shad_palace.
- Old_Helena instances of Tor'WhoDoc and Harry lacking menu-on-use feature
- Music not playing in fmines

Resolved from SEP2013a:
- Valve breaking nightmare_thornlands
- Scaled mobs occasionally having incredible hit range
- Lich Tongue can get its script name cut off and corrupt bank
- Fire aura sound looping
- Sylphiel sometimes refusing to speak to you, if you gave her a quest item before accepting quest.
- Olof's (Thornlands Merchant) shop seems to be busted.
- Kodiak not dropping high carb treats on Bloodrose
- Map vote system neglecting to send ballots to random players when some players are AFK.
- Combat music system issues
- HLDM map recognition issues
- Items dropped on death exploits (untested)
- Push DOT: Winterwolf Alpha
- Push DOT: lightning bird in aluhandra2
- Shender_East boss guardians still flying backwards on projectile
- Shender_East guardians locking when floating directly above target
- Various summoned NPCs being stuck in things/players
- Various variable type conflict issues among the scripts
- trigger_push scriptevent feature
- Bank losing items when transfer of ownership is in progress
- Serpent gauntlets doing fire damage
- Individualized chests reporting >500gp value rewards to others
- nightmare_edana initial boss sequence
- Sorcs lightning resist
- Bludgeon axe max flight timer, when thrown by NPC
- Goblin Pouncer pouncing certain spell effects
- Chat flags for bloodstone quest lines
- Issues with slotting and deploying a charged weapon
- Check Orc_for chests spawning invalid items
- Vgobbie Chief skull projectiles being blocked by monsterclips
- Demon Bludgeon Hammer effect partly sticking on death
- Certain siege sequence issues
- AFK detection issues
- Scarabs having no XP value
- Thornlands mass de-targeting issue caused by CPU cycle overflow
- Weather FX sometimes sticking between maps
- Orion Bow projectile not recognizing multiple target hits
- const_ovrd initializing during load time
- Friendly battle allies not alerting each other to enemies
- Shaddahr secret guardian secret guardian issues
- Jump brushes on Calrian2 (actually think Valve fixed this.)
- msarea_transition not changing spawn points proper
- mobs failing to calm after not seeing enemy for a few minutes.
- Spiders on ceilings not adjusting projectile origins
- Weapon jamming when coming out of attack, mid another
- Various shops not clearing their inventory in-use signals when closed
- Some Horror navigation and XP issues
- Some functions returning 0 players present, when all AFK
- Various issues with ext_scale add param
- Certain add params not adjusting XP
- Stone spiders not using stone material sounds
- Compensated for Ogre Queen on Underkeep double-running her add params
- Removed some unused weapon and item models that were eating up texture space
- HP bars would display the health level the mob had before being hit, rather than after
- Sometimes skeletons would fail to regain ability to walk, if slain mid-rebirth animation
- Fixed hyperventialiting Khaz Cultits, among other mobs repeatedly doing their 'Wtf did he go?' routine.
- ms_soccer goals sometimes jamming up when too many orcs are within their bounds
- Boss flags: Kfotress boss, mscave Shadahar, Blooodshrine boss
- Issues with arrow reward spawners on M2_Quest
- Fire Bolt p_model was set render less
- Fixed frozen awareness on certain mobs (not got em all yet though)
- Fixed some mobs failing to resume action on thawing from frozen state
- Fixed some freezing sources using wrong methodology to apply their effects
- Holy lance healing unhealable targets
- Issues with duck keydown detection
- Master Priest name change sanitation issues
- Master Priest name change hijack issues
 

Sir Gareth

New Adventurer
Dec 29, 2009
14
0
Just installed the new patch and decided to play the new maps (rmines).

Currently ive been having nightmares with crashes this update. But my biggest headache right now is that in rmines i am stuck in spawn after i died to the goblin boss when it had low hp.

I keep getting dragged back into a fixed spawn point when i move or jump. Tried both spawn locations ( the water one and mineshaft)
Things ive tried:
/stuck command. I port around to different spawn points yet i still am stuck in that new fixed position.
suiciding doesnt help i respawn and instantly get stuck in the new spawn location (move and get dragged back)
reconnecting same thing as suiciding
changing characters still stuck in fixed spawn point.

I dont know what else to do. But figured id report it.
 
  • Thread starter
  • Admin
  • #4

Thothie

Administrator
Staff member
Administrator
Moderator
Lead MSC Developer
MSC Developer
Apr 8, 2005
16,199
256
lost
Tails said:
is there going be a new patch? the server dont run as good with d patch or your just having trouble with the servers?
4 player Thornlands (which is my usual gauge for this), is using less cycles than ever before (not even pushing the ~20k mark, where it used to hover near ~50k). MiB's new hash system seems to be doing its job, so this is the most optimal system we've had in, well, ever, discounting that Valve's HLDS end is always bloating. Think the main problem is that servers are just busier than they've been in over a year, and when one server is running rmines, hunderswamp, or Thornlands (or any other map with 10+ active mobs at a go), they all get bogged down.

MSC will probably always eat more resources than any other game, but this is as good as we've ever had it, really.

Sir Gareth said:
Currently ive been having nightmares with crashes this update. But my biggest headache right now is that in rmines i am stuck in spawn after i died to the goblin boss when it had low hp.
Everytime you go to rmines, or just this one time? Thinking the server fubar'd - happens there a lot, with the insane mob overhead causing odd behavior.
 

Sir Gareth

New Adventurer
Dec 29, 2009
14
0
i've attempted to play the map 4 times in 3 servers.

First few times is when i patched i would get constant fps drops when i would cast spells or pull out weapons (only in that map). attempted that 3 different times reconnecting / new server.

I eventually restarted the machine cause that fixes most issues and it did. Once i got that working i ran that map again only to get the stuck issue. I haven't tried it again but ill test it out some more and let you know my results.

Edit: Just ran the map two times. Seems to be working correctly now. The only odd ball thing that happened during the stuck situation was people connecting and crashing repeatedly. That may have had an effect on it?
 

TheOysterHippopotami

Active Adventurer
MSS Developer
MSC Developer
RiP
DarkTide
Sep 6, 2009
1,213
41
31
Edit: Just ran the map two times. Seems to be working correctly now. The only odd ball thing that happened during the stuck situation was people connecting and crashing repeatedly. That may have had an effect on it?
This actually sounds like it might be the same kind of weird lag we encountered the other day which prevented everyone from moving. The server crashed shortly afterwards.
 

Lucifer Majiskus

Active Adventurer
Sons of Babel
Alpha Tester
Mar 9, 2009
1,230
38
23
An igloo far up North.
TheOysterHippopotami said:
Edit: Just ran the map two times. Seems to be working correctly now. The only odd ball thing that happened during the stuck situation was people connecting and crashing repeatedly. That may have had an effect on it?
This actually sounds like it might be the same kind of weird lag we encountered the other day which prevented everyone from moving. The server crashed shortly afterwards.
Yeah people frequently all get booted and it gives an error like "Client not found on server" or some jazz :/

(This happens after 600+ping)
 

TheOysterHippopotami

Active Adventurer
MSS Developer
MSC Developer
RiP
DarkTide
Sep 6, 2009
1,213
41
31
In underpath, there seems to be a really long delay between "the ogre matriarch rages" message and her actual spawning. It's like 30 seconds at least, maybe more. I actually thought she wasnt going to spawn and that I was stuck in the bossroom until she decided to show up out of thin air.
 
  • Thread starter
  • Admin
  • #9

Thothie

Administrator
Staff member
Administrator
Moderator
Lead MSC Developer
MSC Developer
Apr 8, 2005
16,199
256
lost
Think her trigger is actually at the entrances to her chamber, so if you're in there when the counter's up, she wont spawn until either you go out and back in, or someone else enters. In the meantime, ya just get that looping roar and shake outside to guide players to her.

Sloppy solution would be to change her trigger spawner boxes into one huge one that covered her whole chamber and the entrances.
 

TheOysterHippopotami

Active Adventurer
MSS Developer
MSC Developer
RiP
DarkTide
Sep 6, 2009
1,213
41
31
Think her trigger is actually at the entrances to her chamber, so if you're in there when the counter's up, she wont spawn until either you go out and back in, or someone else enters. In the meantime, ya just get that looping roar and shake outside to guide players to her.
well, she definitely spawned after a while, even though no one was there to trigger her.
 

Thothie

Administrator
Staff member
Administrator
Moderator
Lead MSC Developer
MSC Developer
Apr 8, 2005
16,199
256
lost
Odd... Did ye not wander about?

underpath_queen_spawner2b.gif

The larger part of the two part trigger brush covers the floor towards the entrance of her chamber, so if ya back up towards the waterfall or entrance, she'll spawn. The smaller bit is at the other cave entrance, as otherwise you'll miss it, if you come in through the top.
 

TheOysterHippopotami

Active Adventurer
MSS Developer
MSC Developer
RiP
DarkTide
Sep 6, 2009
1,213
41
31
The larger part of the two part trigger brush covers the floor towards the entrance of her chamber, so if ya back up towards the waterfall or entrance, she'll spawn. The smaller bit is at the other cave entrance, as otherwise you'll miss it, if you come in through the top.
Oh, I see. That's probably how it happened then.

While I'm here I'll mention that the new music in m2quest (that piano thingy I sent you) is getting cut off before it finishes. Any way you could change it so the entire tune gets played?
 

MS:C community

Old Skool Apostle
Alpha Tester
Jul 7, 2011
484
91
Bug: In catacombs, one of the 'corpse flames' of the Hollow One managed to instakill me while I was using mana font.

Edit: Also, I beat the entire map with Shiro and Petro Hushtros and noone else joined or left during the run. HP in-game: 2763. The mobs were tier III (except those 'down-adjusted') but the chests were tier II. Intentional?

Edit 2: Upon closer inspection I noticed the chests all said this:
f0gFTZs.jpg

Edit 3: Another bug: Perfect FCK small icon appears to be that of the folded steel blade or rusty knife (hard to tell).
 

MS:C community

Old Skool Apostle
Alpha Tester
Jul 7, 2011
484
91
old_helena crashed twice in a row now at the very end... I'm almost positive it's the fire shamans.
That doesn't explain the successful run we had before the two crashes, but the final two runs (both crashes) the server just stopped the moment a shaman fireball appeared to hit something.

Edit: Run #4 didn't crash even though the shamans lived longer than we usually let them. Oh well.
 

MS:C community

Old Skool Apostle
Alpha Tester
Jul 7, 2011
484
91
That poisoner in orc_for can cast his acid cloud anywhere in the map. Even if you have never seen him (i.e. if some other player spawned him) he can attack you with it across the entire map. Intentional?

I also believe it sometimes stuns you (this must be a bug).
 

Thothie

Administrator
Staff member
Administrator
Moderator
Lead MSC Developer
MSC Developer
Apr 8, 2005
16,199
256
lost
TheOysterHippopotami said:
[m2_quest music]
Prob didn't adjust the length when I swapped out the song. (Actually, I know I didn't - as I just copied over the old copyrighted music - didn't adjust the maps - so this is probably true of a lot of the replacement music.)

Sadly, rigging up the playmp3 function to auto-detect the length of a song turned out to be a whole lot more complicated than initially predicted.

MSC:C said:
[ Treasure II (Multi) III ]
Damnit, thought I fixed that... It's probably actually a Tier 3 chest, it's just, for some damned reason, adjusting its name twice during the process.

tdebugt CHEST_AVG_LEVELS on it, I suppose... This should report to console without making things talk and/or risking a server crash now, and be a bit cleaner.

MSC:C said:
[more icon inventory inconsistencies]
I've no idea how this happened, given that I batch converted these (though to mass copy the palette I had to rig up a macro. Wondering if delays fuxed up the macro - but I don't see how.)

MSC:C said:
[dq/voldar's infinite seeking cloud of poison stun]
Will examine... V. old script, and the first time he's been placed somewhere that you're likely to be out of LOS for long. Stun bit is probably similar to the DOT/push issues common to older scripts.
 

Lucifer Majiskus

Active Adventurer
Sons of Babel
Alpha Tester
Mar 9, 2009
1,230
38
23
An igloo far up North.
Got to the last (shitty) section of deralia sewers, crashed just before mummies...

Ravens mace speed effects turn off randomly, and come back on.

Bludgeon hammers only leech about 1/2 the time.
 

zeus9860

Adventurer
Blades of Urdual
Crusaders
The True Followers of the Lost
Alpha Tester
Feb 28, 2008
2,549
18
27
lolwut
Lucifer Majiskus said:
Ravens mace speed effects turn off randomly, and come back on.
It has always been like that, unless its turning on and off more often than usual.


Also, a report i noticed on day release of feb patch. You can't vote using # keys anymore, this will likely also effect other similiar menus like clearing off a memorised spell. Basically i'm forced to use the cursor now...
 

zeus9860

Adventurer
Blades of Urdual
Crusaders
The True Followers of the Lost
Alpha Tester
Feb 28, 2008
2,549
18
27
lolwut
Urdualian shield causes massive lag for me, i figured it out just now. I drop the thing, run around happily ever after with no lag spikes, i pick up the thing and the lag drops on everyone in the server.

I do think this shield should be renamed to lagparty shield.
 

Thothie

Administrator
Staff member
Administrator
Moderator
Lead MSC Developer
MSC Developer
Apr 8, 2005
16,199
256
lost
zeus9860 said:
Also, a report i noticed on day release of feb patch. You can't vote using # keys anymore, this will likely also effect other similiar menus like clearing off a memorised spell. Basically i'm forced to use the cursor now...
Yeah, sadly we had to disable the shortcut keys for menus due to sploitz. :(

Ravenmace will do that in laggy conditions, as will anything else with a periodically re-applied effect. Speed effect will, similarly, persist for several seconds after putting it away.

Will examine UShield.
 

zeus9860

Adventurer
Blades of Urdual
Crusaders
The True Followers of the Lost
Alpha Tester
Feb 28, 2008
2,549
18
27
lolwut
For some reason, when i was alone, i dropped it, no lag, i passed it over to another person, lag occured, said person dropped, lag dropped or was low (ping @ 300 or less).

Gonna check other shields in my galat, see if it also happens with them. This is weird because one my alts has a u shield and works fine. The one on my main was either corrupted or something else was causing conflicts with it.

EDIT: It's not just ushield... Tested demon shield just now, same issue, except i could put this one in bag (seems to remove the problem). Ushield inside the bag is permanent slowdown (bug?). Going to try and join people see how it goes in a few and test some more...

EDIT2: People running around with shields cause no issues for me, carrying a shield in a container causes no issues. Carrying any shield in hands or back = massive lag. Also, despite all of these shield problems, my main seems to have slightly more unstable ping than my alts, i tested with one of my alts that carries shields in the back. My alt harldy goes over 180 ping on edana. My main gets 220 ping at times and when i hit walls with my fists or weapons, ping increases by 50+ hitting 250+ easy. With one more player in the server, i was experiencing ~300 ping on my main, alt was stable like other players. Equipping armour causes minor lag spikes in main character. (for me and others in the server, doesn't happen with alts)
 

Thothie

Administrator
Staff member
Administrator
Moderator
Lead MSC Developer
MSC Developer
Apr 8, 2005
16,199
256
lost
Lucifer Majiskus said:
Bludgeon hammers definitely don't leech every hit anymore. Not sure if this was intentional, but :oldcry:
Nope, and looking at it, not seeing any reason it would fail, save maybe lag.

TheOysterHippopotami said:
Ice shielding other players is not awarding any damage points.
Will examine.
 
Status
Not open for further replies.
Top