1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Intense ping problem

Discussion in 'Troubleshooting' started by OverKill1376, Mar 22, 2017.

  1. OverKill1376

    OverKill1376 New Adventurer

    21
    0
    Jan 1, 2014
    Iran, Tehran
    Hey, so I'm having some ping problems.
    I've been playing MSC since 3 years ago or something. Anyway, about 2-3 times (excluding right now) I've had a sudden unusual ping problem where when I view a server on the Server Browser, it has low ping for me (around 140 because I live in Iran). But when I join that server, my ping suddenly starts going way up. Between 400-1100. Keeps going up and down for no reason. I have no background downloads and I've tried port forwarding but it doesn't work.
    As I said, I've had this problem before. I couldn't fix it back then either. I just came back a while later (probably months) and it was magically fixed.

    Right now I'm having this problem and it's really annoying.


    Does anyone have any idea on what I should do?

    IMPORTANT: I also sometimes get kicked form the server with the message "Reliable Channel Overflowed". I think this is the key word for my problem.


    Extra info: as I said, the ping generally being high, it does go up and down every few seconds . From a minimum of 380 to a maximum 1400. So if I run straight, at one point it will be a fluid move and at one point I will suddenly get stuck or be pushed forward.
    I don't think it's because of my computer because I haven't change my computer or it's parts since then. And my internet service has actually been better than ever.
    My game is up to date. (NOV2016a update).
    I have tried reinstalled Half-Life and MSC but it didn't work.
     
  2. Thothie

    Thothie Administrator Staff Member Administrator Moderator Developer

    15,079
    54
    Apr 8, 2005
    psycho-oligist
    lost
    Hopefully I don't get GITMO'd for giving technical advice to Iran. (Sh*t's craycray here, ya never know.)

    Since your character is loading, this isn't the character corruption problem... There's a lot of things that can cause other sorts of Reliable Channel Overflow, but 99% of the time it's this:

    Are you using a wireless router?

    Stop doing that - get an ethernet cable and a drill, and fix that sh*t.

    If that's not the problem, you can check your network cvars (some of these are defunct, but just for good measure):
    Code:
    cl_updaterate 20
    cl_cmdrate 30
    fps_max 999
    rate 20000 //may not report
    cl_rate 20000 //may no longer exist
    ex_interp 0
    cl_cmdbackup 6 //may no longer exist
    fps_modem 30 //may no longer exist
    
    If that doesn't fix it either - it maybe the install or config be fubared, in which case I'd try doing a from-scratch install again (remember to do the main installer and then the betapack).

    While ya got the hood open, right click on MSC in your Steam library, open Properties, click "Set Launch Options...", and add:
    Code:
    -num_edicts flags to 1500
    Which is probably not the problem (usually makes for a different error), but it covers another base at least.
     
  3. OverKill1376

    OverKill1376 New Adventurer

    21
    0
    Jan 1, 2014
    Iran, Tehran
    Heheh, good joke. Everytime you reply one of my questions you always come up with a new joke :D


    Alriight, it worked! I reinstalled the game, popped in a cable and used all the configs you said and it's working great! Thanks a lot Thothie, really appreciate it!
     

Share This Page