Bug Reports DEC2010a

Status
Not open for further replies.
  • Thread starter
  • Admin
  • #1

Thothie

Administrator
Staff member
Administrator
Moderator
Lead MSC Developer
MSC Developer
Apr 8, 2005
16,199
256
lost
:arrow: = Working on it, :?: = wtf/unconfirmed, :idea: = fixed next release

Known issues

Minor
:idea: ms_bloom_level cvar not sticking
:arrow: Various Lodagond-4 crashes
:idea: demontemple needs moar spawns
:?: Lack of level up sfx for Polearms (for some players)
:idea: Pets deleting on completion of sorc_villa
:idea: eagles DOT doing push (fairly old lack-of-flag issue)
:arrow: Pharaoh lance leaving creatures immune to stun afterwards

Aesthetic
:idea: Still snowing in Edana after December. :\
• Characters from before DEC2010 will be partly invisible or scrambled on the char selection screen until they have spawned in the world under the new patch.
:idea: When first created, new characters are invisible on char selection screen.
:idea: Both character models are invisible on the character selection screen.
:idea: Bloom is blinding! (Tap "b")
:idea: Weather sticking between maps, if next map has no weather defined
:?: Some player's report additive render weapons not rendering so in first person, or otherwise rendering incorrectly (Felewyn Shard, Hoarfrost Blade, GIB, etc.)
:?: Disconnecting while dead results in invisible body and armor on reconnect.
• Using changelevel instead of votemap or admin_map may cause various texture issues.
• Female model is fugly as sin.


Ancient/Perpetual
Known Ancient bugs:
- No Free Edict Errors (ED_Alloc:no free edicts), usually the result of overloading the server in one way or another. You can *try* hosting with the -num_edicts flag, however, this may prevent some maps from loading. We're constantly working to mitigate this bug.
- All entities invisible bug (type kill in console to cure).
- Lights/sprites not going away / sticking to other objects (Sticky client-side effects)
- Occasionally a weapon/spell will stop doing damage until it is unequipped then re-equipped.
- Can't use charge attack in laggy conditions. (Work around: use +special or +uber)
- Sitting animation bugs (sometimes saves to character for awhile)
- All water sometimes goes white (texture stretch bug, restart)
- Typing issues in chat. Especially with European keyboards.
- Various Health/mana indicator madness (see also yonder)
- Small sack holds stuff it should not.
- Ticket Bank freaks if you have more than one of the ticket or item you are trying to trade
--> Galat chest does not have this issue.
- Double attack bug, most prominant with xbows
- All tomahawks appear as fire tomahawks in third person

Also Not liable to go away soon:
- Some monsters still capable of some acts while frozen (jumping, etc.)
- Orion Bow jamming sometimes, (I've no idea how to fix this without dropping the whole charged weapon concept.)
- Jumping from server to server without closing HL screws with FN functionality (solution: Close half-life before joining another game.)

Resolved from MAY2010a:
• Some players still can't delete their own characters
• Sploitie bits in Umulak
• Hoarforst ice shards fail
• Upgrade your demon claws to Infernal, if you don't like them.
• Lots of other stuff that didn't make the top page.
 

Orochi

New Adventurer
MSS Developer
MSC Developer
Jun 12, 2006
790
0
31
On a Bus
If someone wants to redo the animations that the male player model has for a female boneset then by all means do so. Otherwise, yer not gettin' a new female player model.
 
  • Thread starter
  • Admin
  • #3

Thothie

Administrator
Staff member
Administrator
Moderator
Lead MSC Developer
MSC Developer
Apr 8, 2005
16,199
256
lost
I dun think you originally intended the female model for public consumption, so I don't blame you for the state it's in - being kind of a placeholder and all. Granted a new one means all the work of re-arranging the armor and what not as well. I've yet to see how easily we can swap models out entirely - I know it's *possible* though, so it may not need to go with the original boneset. Granted, it'll require a lot of code changes to swap out models entirely - at the moment it's only designed to work with submodel sets.
 

Borya

New Adventurer
Blades of Urdual
Rock tossing trolls are completely derp while in optimal polearm range (at least, for the spear, will re-test though at Dridje's suggestion). Also, me bloom settings didn't stick after restarting msc (but then again, I set it via the console).
 

J-M v2.5.5

BANNED
BANNED
Feb 26, 2005
5,677
1
31
Nijmegen, the Netherlands.
Putting ms_bloom_level "0" in autoexec.cfg, config.cfg and userconfig.cfg still doesn't disable it per default.

Flashy disco lights and "You have leveled" messages didn't appear at any time when leveling Pole Arms from 1 (0,0,1) to 2 (1,2,1).
 

TheOysterHippopotami

Active Adventurer
MSS Developer
MSC Developer
RiP
DarkTide
Sep 6, 2009
1,213
41
31
The white potion is once again plaguing my screen

Bloom does nothing except lag me to death. There is no change in visuals whatsoever, but the game is unplayable with bloom enabled.
 

Orochi

New Adventurer
MSS Developer
MSC Developer
Jun 12, 2006
790
0
31
On a Bus
Hoarfrost shard can't use manual parry since Ice Circle is on right-click. Should move it to 2nd charge.

Also, I goofed on a couple of models: the iceblade isn't using the p_model I made for it, I must have flubbed it, and the Litch Tongue is still being held in the wrong hand. I suspect you may have tried to fix it at the same time I did, so just swap the hands around and you'll be good to go.

EDIT: Apparently you used the wrong p_weapons models, because some of the models have texture glitches now. I'll resend the lot of them.
 

Keldorn

New Adventurer
MSC Developer
Mar 12, 2009
531
0
31
New York, NY
Something is a bit odd about the ethereal dagger's swing animation, but I think someone reported that a while ago.
 

Thothie

Administrator
Staff member
Administrator
Moderator
Lead MSC Developer
MSC Developer
Apr 8, 2005
16,199
256
lost
Orochi said:
Hoarfrost shard can't use manual parry since Ice Circle is on right-click. Should move it to 2nd charge.
Which would nerf it to hell. >_>

Borya said:
Setweather doesn't stick but for all of 45 seconds or so. Which gets old quick if the skybox decides to become a migraine-inducing shade of bright. Props for it being spamable I guess though.
Setweather doesn't lock, unlike Clearsky - however, it shouldn't be cycled over any faster than usual. It just gets cycled out on the next map weather change, which happens every 3 minutes or so.

Orochi said:
EDIT: Apparently you used the wrong p_weapons models, because some of the models have texture glitches now. I'll resend the lot of them.
p_models1&2 are the same from the MAY2010 pack, as I didn't have a chance to test all those. p_models3&4 are from FER.

J-M v2.5.5 said:
Putting ms_bloom_level "0" in autoexec.cfg, config.cfg and userconfig.cfg still doesn't disable it per default.
WTF'ness... :\ Tis a standard cvar, should stick like the others. :/ - Tried setting it in Advanced Options?

J-M v2.5.5 said:
Flashy disco lights and "You have leveled" messages didn't appear at any time when leveling Pole Arms from 1 (0,0,1) to 2 (1,2,1).
Hrmm... Shall have to examine script, maybe fubaring on the skill name.

TheOysterHippopotami said:
The white potion is once again plaguing my screen

Bloom does nothing except lag me to death. There is no change in visuals whatsoever, but the game is unplayable with bloom enabled.
Delete msc\gfx\vgui\hud_main.tga as per usual troubleshooter. Full installer, needless to say, brings the thing back.

Also update your drivers, this is supposed to have been resolved - and if bloom's having no effect, but still raping your FPS, something be wrong. (Meanwhile hit "b" to turn it off.)
 

J-M v2.5.5

BANNED
BANNED
Feb 26, 2005
5,677
1
31
Nijmegen, the Netherlands.
Thothie said:
WTF'ness... :\ Tis a standard cvar, should stick like the others. :/ - Tried setting it in Advanced Options?
Yup.

Thothie said:
J-M v2.5.5 said:
Flashy disco lights and "You have leveled" messages didn't appear at any time when leveling Pole Arms from 1 (0,0,1) to 2 (1,2,1).
Hrmm... Shall have to examine script, maybe fubaring on the skill name.
Seems to work great for Avacado Maelstrom though, but Keldorn has the same problem as I do. Maybe it's related to how strong characters are? Keldorn and I both have fairly hefty characters. I have Pole Arms 5 now but I still haven't seen the level-up gimmicks. It's not a big issue though, I am actually leveling it.
 

jon50559

Adventurer
RiP
Crusaders
The True Followers of the Lost
MSR Developer
Mar 6, 2010
640
11
26
U S A
I was having some weird problems in Chapel with the textures, the rock walls(and possibly other things) were being replaced with the ground texture, and the river running in front of the chapel was looking all sorts of screwy. Not sure if this is just on chapel, but it's where I encountered the problems.
 

Thothie

Administrator
Staff member
Administrator
Moderator
Lead MSC Developer
MSC Developer
Apr 8, 2005
16,199
256
lost
Visit it again, and see if it repeats? That's usually the sort of thing that crops up with using changelevel instead of admin_map or votemap. Just cycling through a lot of maps can sometimes cause texture bugs too (ala texture stretch bug).
 

Thothie

Administrator
Staff member
Administrator
Moderator
Lead MSC Developer
MSC Developer
Apr 8, 2005
16,199
256
lost
Temporary test script package, for mappers:
http://www.thothie.com/msc_dev3/Test_Sc ... e_Beta.rar
A lot of the examples provided are bad, as many of them are old convention, or have mystery issues (usually commented upon). The documentation is also not really geared towards non-developers, and even the example script "How_to_make_a_monster.script" makes things appear much more complex than they are, and needs a re-write.

.script files can be opened with notepad, as can the ms.stx EditPlus syntax file, which doubles as a nearly complete, if cumbersome, reference. EditPlus is your best bet when working with scripts though, so long as you configure it to use that ms.stx file.


I'll try to make an in-game appearance again tomorrow (sans aliases)... I've got RL stuff to finish up, and gotta work on a proper scripting wiki.
 

Thothie

Administrator
Staff member
Administrator
Moderator
Lead MSC Developer
MSC Developer
Apr 8, 2005
16,199
256
lost
The... Hell...

Eh... It'll probably go away come 2011. (MSC Christmas currently runs through December.)
 

Dejiko

New Adventurer
Aug 28, 2007
225
0
31
In Edana, the pet boar on the hill was a wild boar instead of a tamed boar. (not entirely sure this is new, I haven't been up there in a while).
 

The Man In Black

Administrator
Staff member
Administrator
Moderator
Lead MSC Developer
MSC Developer
RiP
Jul 9, 2006
6,892
54
It's not a pet boar. Guy has always complained about a boar problem. Never seen it as a 'tamed' boar, either.
 

J-M v2.5.5

BANNED
BANNED
Feb 26, 2005
5,677
1
31
Nijmegen, the Netherlands.
Randomly crashed in heras (after being there for at least 25 minutes already) with this bug:
missing_model_bug.png

The actual model is still there, and I don't think it's related to heras, and it only happened once. Still though, figured I'd report this.

TBH
 

Orochi

New Adventurer
MSS Developer
MSC Developer
Jun 12, 2006
790
0
31
On a Bus
Sounds like something not being precached.

Also, apparently the update FUBARed something in the internals because the server list takes forever to load, and sometimes doesn't at all.
 

Lucifer Majiskus

Active Adventurer
Sons of Babel
Alpha Tester
Mar 9, 2009
1,230
38
23
An igloo far up North.
Orochi said:
Sounds like something not being precached.

Also, apparently the update FUBARed something in the internals because the server list takes forever to load, and sometimes doesn't at all.
I can confirm this. I was sitting there for 3 minutes waiting for it to load.
 

zeus9860

Adventurer
Blades of Urdual
Crusaders
The True Followers of the Lost
Alpha Tester
Feb 28, 2008
2,549
18
27
lolwut
Thothie said:
Visit it again, and see if it repeats? That's usually the sort of thing that crops up with using changelevel instead of admin_map or votemap. Just cycling through a lot of maps can sometimes cause texture bugs too (ala texture stretch bug).
Happens when you do votemaps aswell, Chapel is a good example to see how messy things might end up after a votemap... I've seen walls there with crate textures and weird colours for some reason too. This also happens in many maps. Only way i see to temporarly fix it is to restart the game and reconnect.

I think this has been reported in the alpha testing but sometimes people cant read text in the game, happened 2 times to myself already and i saw few other people going through the same. First time my text got screwed was after i sprayed a wall, second time was when someone joined the server i was on, text got screwed up for no reason apparently (this recently happened to 2 other players aswell while i was in the server watching them restart the game).
 

Stoned

New Adventurer
Jul 24, 2009
856
0
24
By the way...

http://img233.imageshack.us/f/heras0000.png/

http://img132.imageshack.us/f/heras0001.png/

That has happened to me before when I was alpha testing. Has this happened to anyone else? It could just be me.

Oh yeah, when I was using the trident I could use the charges when I was at 12 proficiency when I think you were suppose to be able to use them at 13 due to the fact that I didn't do any extra damage with the 1st charge at 12 nor did I hear that fabled grunt of the msc dude.
 

Thothie

Administrator
Staff member
Administrator
Moderator
Lead MSC Developer
MSC Developer
Apr 8, 2005
16,199
256
lost
Orochi said:
Sounds like something not being precached.
Precache makes a different error (no pop-up), and that particular model is precached at game launch. HL musta lost it for some reason - hope it's a one time memory corruption thing.

Orochi said:
Also, apparently the update FUBARed something in the internals because the server list takes forever to load, and sometimes doesn't at all.
We've no control over the server browser lists, they are part of Steam. Folks have been complaining about the Steam browser sucking for months now...
 
Status
Not open for further replies.
Top