1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Black menu on start -nofbo does not fix

Discussion in 'Troubleshooting' started by Lt.Green, Dec 17, 2016.

  1. Lt.Green

    Lt.Green New Adventurer

    51
    0
    Jan 21, 2014
    When I start the game on my laptop I see the menu background for a moment and then get a black screen, I can hear music, move mouse around and hear menu buttons, I had the same issue with regular Halo Life and -nofbo in the launch options fixed it.

    However, setting - nofbo in launch options for MS:C does not fix the issue, i'm not sure if MS:C is ignoring the launch option somehow because it is third party mod to steam or not. Other graphics launch options have not helped either (-gl or -software, -wide, -gl_vsync 0, etc).

    Does MS:C have an advanced graphic s option that needs to be turned off? (in assuming other than bloom, since it hates me usually, and I'm not in game yet)

    Searching "black menu" and nofbo on these forums did not yield useable results, appologies in advanced if I missed it.

    Similar keyword searches on Google do not find useable results either (ex "half life mod black menu nofbo not fix").
     
  2. Thothie

    Thothie Administrator Staff Member Administrator Moderator Developer

    15,079
    54
    Apr 8, 2005
    psycho-oligist
    lost
    Bloom shouldn't activate until you're in world and have spawned your first character, and then it should give you notice and run a test, but you can try making sure that ms_bloom_level is set to 0 in the config.cfg.

    Beyond that, all I can think of is a faulty install. If you've had Half-Life installed for a few years, I'd try uninstalling and resintalling, and make sure you've installed the full version of MSC and the update package, in that order, from the downloads page.
     
  3. Lt.Green

    Lt.Green New Adventurer

    51
    0
    Jan 21, 2014
    It's a new install of everything, I had only DLed half life to it a month or two ago to get the files and manually transfer to my desktop for validation there.

    I did find a solution much later last night before stumbling off to bed. I setup an old school WON era type shortcut to the actual half life.exe (from the game folder not right click on steam library) and adding -game msc -nofbo to the target line after quotes. So I'm assuming my guess about setting launch options through steam library and then not being sent to third party mods correctly was it.

    It is however very 'chuggy' when I get in game, I've tried reducing graphics and resolution to minimum, but this doesn't help.

    Anything else I might need to add to the target line? Options or commands that get run by MS:C automatically when launched from steam that might not run this way?
     
  4. Thothie

    Thothie Administrator Staff Member Administrator Moderator Developer

    15,079
    54
    Apr 8, 2005
    psycho-oligist
    lost
    All I can think of is yonder. If it's an Intel GPU, r_dynamic 0 might be of particular help - those cards tend not to like dynamic lighting in legacy GL. (If it gets too dark to see underground as a result, you can try adding fog via setweather fog_white 1 1, or whatnot.)

    In relation to your other thread, you can run the HLDS and the client on the same box, you just have to change the port of the HLDS (to maybe 27016). So if you're using your laptop as an alternative client in order to have the HLDS, that maybe another solution. Depending on how mean the rig is, you might also try changing the affinity so that the client and HLDS are on different cores.
     
  5. Lt.Green

    Lt.Green New Adventurer

    51
    0
    Jan 21, 2014
    Seems like some of the things are trying to help and some are not, I'll continue playing with these settings. I did for a bit get the sound chugging the other guys was talking about with ALL the settings, like I said, I'll keep playing with them and see if I can get a reasonably useable combination.

    One interesting thing, I chugged up out of the temple in edana and started fighting rats, when looking down toward them and the ground and not up and out, the chuggyness goes away, since obviously I'm looking at the floor and it's not rendering the whole map.

    Yes it is an Intel card, integrated graphics cause my discreet card (early Nvidia optimus) does not work anymore, considering the key word being intergrated, I may just be up the creek.

    And yeah, once I got home I transfered a copy of the HLDS setup to my desktop, and decided that yes, duh, my desktop is powerful enough to do everything by itself (8 Core AMD black edition at 4 ghz, 16gb ram with only 2 sticks in, which reminds me need to fill those other two slots sometime) and I used to do it all the time, idk what I was thinking at first. Now my main hope was to use the laptop for an additional client, which may not be 100% feasable.
     
  6. greatguys1

    greatguys1 Active Adventurer Developer Warriors of the North

    279
    34
    Apr 20, 2013
    Yes
    May be a longshot, but if you have Razer Synapse, shut it down while playing. It doesn't like MSC for some reason.
     

Share This Page